Jump to content


Application hangs when reverting files


  • Please log in to reply
5 replies to this topic

#1 m_parker

m_parker

    Newbie

  • Members
  • Pip
  • 7 posts
  • LocationChicago, IL

Posted 11 December 2019 - 06:05 PM

A few different times now I've tried to revert a changelist as I have thousands of times before, and the output says

p4 revert -a file1 file2 {6 more items}
no files reverted (all files were either changed or opened for add, delete, or branch)

Then immediately the loading bar in the lower right side starts looping, but it never finishes and the program is now inoperable.  *Note that -a is in the output even though I did not click Revert Unchanged.*  One time there was only one file in the CL and no shelved files, so I deleted it in Windows Explorer, did a force Get Latest, and tried again and then it worked.  This time, with 8 files in the changelist and all shelved, I can try the same thing but it's much less convenient.  Instead, I performed a command-line revert which worked as expected (p4 revert -c 570975 //...)  I can reproduce this 100%, but I have to kill P4V with Task Manager every time I try.  Just to check, after the command-line worked I unshelved one of the files and tried again in P4V with the same bad result, and then tried a separate changelist with shelved files and got it again.

Version P4V/NTX64/2019.2/1883366

#2 m_parker

m_parker

    Newbie

  • Members
  • Pip
  • 7 posts
  • LocationChicago, IL

Posted 12 December 2019 - 07:28 PM

From some brief tests, it appears to be working today, though I couldn't guess as to why.  Hopefully just an odd state that resolved itself.  I'll report back if I start seeing it again. :)

#3 Matt Janulewicz

Matt Janulewicz

    Advanced Member

  • Members
  • PipPipPip
  • 224 posts
  • LocationSan Diego, CA

Posted 17 December 2019 - 08:41 AM

Out of curiosity, are you running a commit->edge architecture?

You didn't describe it this way, but we have that architecture and default to global (on the commit) shelves. Every so often (maybe once a month) someone hits the stop button (or ctrl+c on the command line) mid-shave or mid-submit (which shelves in the background) and we end up with zombie pids on the edge server. They eventually work themselves out (after many hours sometimes) but after until then, doing the same submit/shelve will hang P4V in an infinite loop (while it's waiting for the locks to go away.) In extreme cases I have to 'p4 monitor terminate/clear' then 'kill pid' to get everything going again.

Next time this happens it might be interesting to do a 'p4 monitor show' on the server you're submitting to (as well as perhaps p4 lockstat) to see what the server thinks is going on, and whether it looks like two identical or nearly identical requests are happening with that particular workspace.
-Matt Janulewicz
Currently unemployed, looking for work in Boise, ID!

#4 davidair

davidair

    Member

  • Members
  • PipPip
  • 20 posts

Posted 18 March 2020 - 06:08 PM

I've been seeing this issue several times - when running a revert using P4V, the following happens:

1. p4 revert -a -c default
no files reverted (all files were either changed or opened for add, delete or branch)

2. The P4V client hangs (window becomes fully unresponsive) with the progress bar spinning continuously in the lower right corner

Running Rev. P4V/NTX64/2019.2/1904275

The only option is to kill P4V.

When running p4 revert -a -c default, no files are reverted.
When running p4 revert ..., files get reverted.

The fact that P4V hangs feels like a bug.

#5 Domenic

Domenic

    Advanced Member

  • Members
  • PipPipPip
  • 105 posts

Posted 18 March 2020 - 11:31 PM

We've seen this happen too and it appears that the revert window gets hidden behind something else, so it looks like P4V is hung but is waiting on input (to a dialog you can't see). Try ALT-TAB'ing to see if you can get to the window.

Alternatively, someone wrote a batch file to remove the line for the RevertFilesDialogGeometry entry in %USERPROFILE%\.p4qt\Applicationsettings.xml which also seems to "fix" the issue by resetting the coordinates. If you do that make sure to restart P4V.

#6 davidair

davidair

    Member

  • Members
  • PipPip
  • 20 posts

Posted 19 March 2020 - 01:57 PM

Thank you Domenic!

I have a dual-monitor setup and was not able to find the blocking modal window by ALT-TAB'ing, but editing the %USERPROFILE%\.p4qt\Applicationsettings.xml file by hand and removing the PropertyList entry containing RevertFilesDialogGeometry fixed it.

Indeed, the Revert operation needs to prompt the user for all unchanged files - but the modal dialog was displayed off-screen, giving the impression P4V was just "hanging".




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users