Jump to content


Latest P4Merge failing to start on MacOS 10.15.2


  • Please log in to reply
1 reply to this topic

#1 jlczuk

jlczuk

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 17 January 2020 - 03:31 AM

I tried using p4merge in the past and found its cognitive overload too much to bear.  But I've circled back to try to use it again as my git merge/diff tool.  I was absolutely ecstatic to see how much the UI has improved!  Sadly, after saving my rather complex merge and closing, I get this error and all my changes were lost.

The first time I ran git mergetool I got the following error.  Prior to the error I got git messages merging files and several files were listed.  Then this:
launchp4merge(94222,0x10de19dc0) malloc: Incorrect checksum for freed object 0x7fc3d3604cb0: probably modified after being freed.
Corrupt value: 0x0
launchp4merge(94222,0x10de19dc0) malloc: *** set a breakpoint in malloc_error_break to debug
/Applications/Xcode.app/Contents/Developer/usr/libexec/git-core/mergetools/p4merge: line 128: 94222 Abort trap: 6		 /Applications/p4merge.app/Contents/Resources/launchp4merge $PWD/$BASE $PWD/$LOCAL $PWD/$REMOTE $PWD/$MERGED

Then I reran git mergetool and got the same git merging messages and this:
Normal merge conflict for 'myfile.java':
{local}: modified file
{remote}: modified file
/Applications/Xcode.app/Contents/Developer/usr/libexec/git-core/mergetools/p4merge: line 128: 94925 Segmentation fault: 11 /Applications/p4merge.app/Contents/Resources/launchp4merge $PWD/$BASE $PWD/$LOCAL $PWD/$REMOTE $PWD/$MERGED
merge of myfile.java failed


I am super excited about being able to finally have a decent merge GUI that doesn't drop a cognitive atom bomb on my brain every time I use it.  I'm sad that I can't seem to get this to work though.  Hopefully someone has an idea as to what might be wrong.

#2 p4crenck

p4crenck

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 January 2020 - 07:36 PM

Try running the actual executable and not the helper launchp4merge

/Applications/p4merge.app/MacOS/p4merge file1 file2 file3




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users