Jump to content


P4V not connecting


  • Please log in to reply
2 replies to this topic

#1 dtveraas

dtveraas

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 01 February 2020 - 04:19 AM

This is the third attempt at posting on this Forum. If I'm doing something wrong and that is why my posts are not being approved, can a moderator message me about what I'm doing incorrectly?

I'm trying to connect with P4V and I'm getting the following error:

Operation cancelled by user.
Connect to server failed; check $P4PORT.
TCP connect to [IP Address]:1666 failed.
connect: [IP Address]:1666: WSAECONNREFUSED


I've not been able to find any information on troubleshooting this. Does anyone have any leads?

#2 p4crenck

p4crenck

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 11 February 2020 - 05:21 PM

This KB article has some information and troubleshooting about this error:
https://community.pe.../s/article/2960

#3 Miles O'Neal

Miles O'Neal

    Advanced Member

  • Members
  • PipPipPip
  • 183 posts

Posted 11 February 2020 - 06:43 PM

I'm assuming you don't have a firewall in the way.
Did you look at the p4 server log?
What did you set the P4PORT value to for the server itself? (On the server, type "p4 configure show | grep P4PORT"). It needs to be "[IP_ADDR]:1666" or simply "1666" (assuming you are really using port 1666). If it's "127.0.0.1:1666" or "localhost:1666" then you can only connect from the server. If the server is running on Linux, a "ps ax | grep p4d" will likely show you the port on the command line.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users