Jump to content

Writeable flag for typemap folder not working

  • Please log in to reply
2 replies to this topic

#1 adams_s



  • Members
  • PipPip
  • 20 posts

Posted 11 February 2020 - 12:00 PM

We're storing builds of our Unreal Editor in Perforce, and we need these to be checked out as writeable by default (else the editor fails to launch). I'd prefer not using "allwrite" on the workspace, as workspaces contain other files too. I've followed the instructions in this thread (https://forums.perfo...n-entire-folder)

My typemap file looks like

	+w //depot/mystream/UnrealEditor/...

but when I check these files out, they are still readonly. I'm on Windows 10, if that makes any difference.

In the original thread there's no mention of stream, could that be breaking this? I've tried fetching the content in question in the context of the stream it was created in, but we'd also like this to work with virtual streams and path remapping further down the line.

#2 Sambwise


    Advanced Member

  • Members
  • PipPipPip
  • 1192 posts

Posted 11 February 2020 - 03:44 PM

The typemap is applied to new files at the time you open them with "p4 add"; it won't retroactively change existing ones, and it can be overridden with the "-t" flag.  To change existing files you have two options:

p4 edit -t +w //depot/mystream/UnrealEditor/...
p4 submit -d "Changing type to writable."

This will add a new revision with the +w type; once people sync this down the files will be made writable.  I recommend this first approach because it's the most straightforward.

Second approach:

p4 retype -t +w //depot/mystream/UnrealEditor/...

This will retroactively change all the existing revisions to +w.  This requires admin permission, and the change won't be reflected automatically on sync (since as far as the clients are concerned they already have these revisions) until either a new revision is submitted or clients do something like sync to #none and then re-sync.

#3 adams_s



  • Members
  • PipPip
  • 20 posts

Posted 13 May 2020 - 03:00 PM

Thanks for the clear explanation, that really helped.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users