Jump to content


P4V cannot setup localhost WSAECONNREFUSED

help WSAECONNREFUSED localhost failed 1666 p4v local

  • Please log in to reply
1 reply to this topic

#1 scumble373

scumble373

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 26 March 2020 - 07:31 PM

I really need help, I'm trying to setup a local perforce server on my computer, and cannot get it to work.

Here is the error I'm getting:

Connect to server failed; check $P4PORT.
TCP connect to localhost:1666 failed.
connect: 127.0.0.1:1666: WSAECONNREFUSED


I've tried changing the P4PORT in the command line many times, using p4 set P4PORT=1666 and p4 set P4PORT=localhost:1666

I believe I've set everything up correctly, and anything online doesn't seem to help. Why is my connection still be refused?

Please see attached pictures for the way I've tried to setup the client.

Attached Thumbnails

  • perforce1.PNG
  • perforce2.PNG
  • perforce3.PNG


#2 P4Adam

P4Adam

    Advanced Member

  • Staff Moderators
  • 9 posts

Posted 06 May 2020 - 08:38 AM

'Connection refused' generally means one of two things:
  • something is blocking the connection - a firewall, or similar tool/configuration, for example;
  • there is nothing listening on that port.
As you're using 'localhost', I would expect the server to be installed on this machine. Is it running?
If it is running, check the port it is listening on and connect to that.





Also tagged with one or more of these keywords: help, WSAECONNREFUSED, localhost, failed, 1666, p4v, local

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users