Jump to content


Service stopped running


  • Please log in to reply
No replies to this topic

#1 Shokolapka

Shokolapka

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 30 April 2020 - 10:03 AM

Hi. I had a perforce server on a Google Cloud VM, running for a week, when yestarday p4v started returning "Connect to server failed, check p4port".
Ok, I tried p4 info from server - yep, there is an error, can't connect.
Checked netstat and nothing was on 1666. So I assumed that perforce service isn't running.
Then, just to be sure I checked systemctl and didn't see my perforce service there as well.
Then tried p4dctl -list - and there everything looks fine, perforce servise exists, port is set correctly
But when I try to start it with sudo -u perforce p4dctl start perforce - got an eror 'perforce' p4d: '/opt/perforce/sbin/p4d' exited with status 255
Also sudo -u perforce p4dctl stop perforce returnes an error 'perforce' p4d service is not running
So, does anyone have any ideas what caused service to stop running and how to start it again? I'm tempted to just flash the VM and start new from scratch. But again, everything was working fine for 9 days, I had my Unreal Editor connected and made some commits - all was working fine.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users