Jump to content


Getting Started in P4V

P4V Errors UE4 Perforce

  • Please log in to reply
28 replies to this topic

#21 dtveraas

dtveraas

    Member

  • Members
  • PipPip
  • 24 posts

Posted 12 May 2020 - 09:50 PM

I must have been sent off on a tangent. Looking back at the tutorial, I did not actually execute it all. I'll go through that and get back to you. Thanks!

#22 dtveraas

dtveraas

    Member

  • Members
  • PipPip
  • 24 posts

Posted 13 May 2020 - 04:04 AM

I was running through the early steps, when this one snagged me:

"On UNIX and OS X, make the server and client binaries executable, if they aren’t already.
$ cd /usr/local/bin
$ chmod +x p4d
$ chmod +x p4"

After running the chmod ones, the console would return "chmod: cannot access 'p4d': No such file or directory". So I would "which p4d" and saw it was in /usr/bin rather than /usr/local/bin.

I tried to install it all again in /usr/local/bin. The console returned than nothing was installed because helix-p4d was already the newest version.

I know I just removed p4d and p4 and reinstalled, so I figured I would try it again. After removing them I tried to reinstall but I got the already installed message.

Which p4 and which p4d returns nothing now. What happened? How can it already be installed but also not be anywhere?


#23 dtveraas

dtveraas

    Member

  • Members
  • PipPip
  • 24 posts

Posted 13 May 2020 - 04:16 AM

I may have not actually removed it.

I'm not following the same steps as this thread: https://stackoverflo...ce-p4-on-ubuntu

#24 dtveraas

dtveraas

    Member

  • Members
  • PipPip
  • 24 posts

Posted 13 May 2020 - 04:24 AM

Everything appears to be back to before this chmod confusion. The p4d and p4 files are still in /usr/sbin and /usr/bin respectively. When in /usr/local/bin, chmod cannon access either p4 or p4d, but they seem to execute without that error if I cd to their respective locations. Hopefully, that is okay, but it is certainly different from the instructions.

#25 dtveraas

dtveraas

    Member

  • Members
  • PipPip
  • 24 posts

Posted 13 May 2020 - 04:45 AM

When doing this step: https://www.perforce...<br /> <br /> I get this error:
"Listen to localhost:1666 failed.
TCP listen on localhost:1666 failed.
bind: [IP]:1666: Address already in use"

I've been able to connect with p4v and my Unreal Engine 4 source control function, so hopefully this step is satisfied. Do you think that could be the case?

#26 dtveraas

dtveraas

    Member

  • Members
  • PipPip
  • 24 posts

Posted 13 May 2020 - 04:53 AM

I seemed to have enabled SSL at some point. Will that potentially be a problem?

#27 dtveraas

dtveraas

    Member

  • Members
  • PipPip
  • 24 posts

Posted 13 May 2020 - 04:56 AM

I think I figured out how to do the tutorial with ssl enabled. I'll press on.

#28 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 1065 posts

Posted 13 May 2020 - 05:41 AM

View Postdtveraas, on 13 May 2020 - 04:24 AM, said:

Everything appears to be back to before this chmod confusion. The p4d and p4 files are still in /usr/sbin and /usr/bin respectively. When in /usr/local/bin, chmod cannon access either p4 or p4d, but they seem to execute without that error if I cd to their respective locations. Hopefully, that is okay, but it is certainly different from the instructions.

Yes, that's fine.  The instructions assumed that you just downloaded the binaries and don't assume that you already set the permissions on them.  I think when you install via the package thingy it takes care of that for you.

#29 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 1065 posts

Posted 13 May 2020 - 05:42 AM

View Postdtveraas, on 13 May 2020 - 04:45 AM, said:

When doing this step: https://www.perforce.....<br /><br />I get this error:
"Listen to localhost:1666 failed.
TCP listen on localhost:1666 failed.
bind: [IP]:1666: Address already in use"

This means that you're trying to start the server when it's already running -- the port is already in use because there's an instance of the server already listening on it.  Again, this might be something the package installer did?  If the server's already running, you can skip the "start the server" step.





Also tagged with one or more of these keywords: P4V, Errors, UE4, Perforce

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users