Jump to content


Ubuntu 18 install error FATAL:

Ubuntu Install Error

  • Please log in to reply
2 replies to this topic

#1 GregR

GregR

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 09 May 2020 - 08:30 AM

Hi everyone,

I have had to set up a new hosted server today an chose to do it with Ubuntu 18 bionic. It looked like it got and installed the package, went through the configure script options and at the end it came with:
Started 'LRG' p4d service.
Started 1 services
FATAL: Server failed to start!

I have been looking for information that would be able to tell me how to fix this.
Does anyone have any ideas of where I could start. I am a linux newbie.

The only other packages that I have installed on it are firewalld, fail2ban, and cockpit

Thanks in advance
Greg

Attached Thumbnails

  • Ubuntu 18.04 Perforce error.PNG


#2 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 1065 posts

Posted 09 May 2020 - 03:28 PM

See if there's a log file at /opt/perforce/servers/LRG/log.  Hopefully there'll be a more descriptive error message in there.

#3 Matt Janulewicz

Matt Janulewicz

    Advanced Member

  • Members
  • PipPipPip
  • 222 posts
  • LocationSan Francisco, CA

Posted 11 May 2020 - 02:27 AM

I've never installed p4 this way, but in the grand tradition of the Internet I'm going to take a stab at it anyway. :)

I'm suspicious of the P4PORT defaulting to 'ssl:1666', which insinuates that it needs an SSL cert to start. Does the installer otherwise create one? It might be worth a shot to set the port to just '1666' to see if it acts any differently.
-Matt Janulewicz
Currently unemployed, looking for work in Boise, ID!





Also tagged with one or more of these keywords: Ubuntu, Install, Error

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users