Jump to content


P4 Sync: Connection reset by peer error

sync

  • Please log in to reply
No replies to this topic

#1 danielsl

danielsl

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 18 June 2020 - 10:27 PM

Hi guys, we are having an issue which seems related to networking and I couldn't get to a solution from that area yet (as it is a quite complex network infrastructure), in the meantime I wanted to check with you if you have experienced this issue before or have any ideas or suggestions as a workaround. The error we are getting is this one on a p4 sync command:
      Operation: flush2
      TCP send failed.
      write: socket: Connection reset by peer
We see this repeatedly special on large syncs, like in example every time we do the first sync of an entire depot. And this happens when synching to a particular local perforce proxy but not when going to the master p4 server.

We tried some different alternatives in the proxy itself, like reducing the MTU as suggested here: https://community.pe.../s/article/2830, and seems it helped as we started seeing less frequently. But it is still a big issue.

So I wanted to explore with you if there any other workarounds that can be applied to this, or if you have any suggestions for the fix itself. Regarding the workarounds, when I tried these params in the client sync, and retries if I went to the full depot, it still failed consistently on all the 20 retries:

p4 -r20 -vnet.maxwait=600 sync //depot

And as the p4 sync is a transaction (every time it fails it starts again the sync from scratch, and never ends), what we did was to manually split the command in a few different sync operations (with retries) to skip this issue, so we end up in something like this:

p4 -r20 -vnet.maxwait=600 sync //depot/a
p4 -r20 -vnet.maxwait=600 sync //depot/b
p4 -r20 -vnet.maxwait=600 sync //depot/c

So this works, but occasionally we still see the issue. Is there any other workaround for this issue we could attempt from the client side, in terms of params for doing this sync? Also, have you experience this issue before?

Note that we will also keep looking for a solution in terms of networking and proxy side.

Thanks,
Daniel





Also tagged with one or more of these keywords: sync

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users