Jump to content


Fix For: Client Not Recognizing P4Ignore files

p4ignore multiple drives Unreal Engine 4 UE4 setup set P4IGNORE not working p4ignore not working

  • Please log in to reply
No replies to this topic

#1 VellvSagewalk

VellvSagewalk

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 25 July 2020 - 03:31 PM

Hello all,

Newer user to Perforce here, trying to set up an Unreal Project with Perforce for my team - I've been following online tutorials for the P4Ignore setup (create a file, make sure the correct syntax is followed in the .txt, set it as the P4IGNORE variable via 'p4 set P4IGNORE=.p4ignore', everything), but I couldn't for the life of me get this program to recognize my ignores. However, just as I was about to write a post complaining about how I couldn't figure this out or find a post anywhere, I managed to figure out what was going on: in my Client settings file (p4 client in CMD), the Root directory for my p4v client was set to my C:/ drive, specifically the default C:/users/<my username> directory, whereas I installed the client on a directory I had labelled as S:/Perforce/Client.

SO, for those of you like me who might run into this during your first time setup: if you're having issues getting your p4ignore files recognized by the client, while everything else is working (no error on the 'p4 set' function, your p4ignore file is in correct syntax, but p4 ignores still doesn't include your rules, etc.) make sure you perform the following:
  • Go to your command line interface.
  • Type in 'p4 client'.
  • Look for the property labelled 'Root:' and verify that the directory listed there is where you have the client files/executables.
Hope this can help someone like me who couldn't find any kind of reference to this :).

All the best,
Vellv





Also tagged with one or more of these keywords: p4ignore, multiple drives, Unreal Engine 4, UE4, setup, set P4IGNORE not working, p4ignore not working

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users