Jump to content


Errors upgrading a Ubuntu P4 server


  • Please log in to reply
1 reply to this topic

#1 Chaosian

Chaosian

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 26 July 2020 - 05:00 AM

Hi everyone,
I'm a fledgling P4 user running a small Ubuntu-based P4 server.
After recently dealing with an issue of SLL certificates from 2018 (an ordeal in itself) I thought it would be a great idea to update my Ubuntu system, because everything on it was equally out of date. What I didn't realize until the server started giving WSAECONNREFUSED errors again, is that updating perforce seems to be a quite serious and quite involved process not solved with just a simple apt-get.

With no checkpoints established, no good backup to go back to, and no clear process forward- I'm wondering how badly I've messed up the whole server, and potentially the projects therein.

If there's hope yet, here are the status of the current setup.
  • We've been able to solve an issue where running p4d & gave an error:

    Quote

    Database is at old upgrade level 29. Use 'p4d -r /root -xu' to upgrade to level 36
    Now it simply seems to hang in the console and never really start.
  • Based off https://www.perforce...er.install.html, we've tried to run sudo /opt/perforce/sbin/configure-helix-p4d.sh as root. The script gets started but stumbles a few lines in:

    Quote

    Please provide the following details about your desired Perforce environment:

    Perforce Service name [master]:
    Perforce Server address (P4PORT) [ssl:1666]:
    P4PORT=ssl:1666

    Configuring p4d service 'master' with the information you specified...

    FATAL: Need to be logged in as a superuser to perform this operation
Additional info:
  • The P4V client will give the following error if there's an attempt to connect via SSL:

    Quote

    SSL connect to ssl:yadayada:1666 failed (The operation completed successfully. ).
    Remove SSL protocol prefix from P4PORT or fix the TLS settings.
    Attempting to connect without SSL gives invalid user errors.
  • The server will not accept most P4 commands. Something like 'P4 info' gives the following:

    Quote

    Connect to server failed; check $P4PORT.
    TCP connect to perforce:1666 failed.
    Temporary failure in name resolution
  • Running p4 set gives me:

    Quote

    P4CONFIG=.p4config (config 'noconfig')
    P4SSLDIR=/opt/perforce/servers/master/ssl (enviro)
    P4USER=super (enviro)
Any and all help would be greatly appreciated. And hey, even a "you're completely screwed" counts.

#2 P4Jen

P4Jen

    Advanced Member

  • Staff Moderators
  • 155 posts

Posted 27 July 2020 - 11:24 AM

Hi,
For future reference, this KB article provides details about what you can expect to see when upgrading packages, and also links to
the documentation in the Helix Core admin guide:
  https://community.pe...s/article/16525

Before trying anything else I suggest you first backup your depot files, and take a checkpoint.
To take a checkpoint, run:
  p4d -r <P4Root> -jc

Also, this forum post may provide some hints about the 'temporary failure in name resolution" error:
  https://forums.perfo...ilure-on-linux/

Once you have a checkpoint and backup of archive files, you can reinstall the packages if necessary, then restore your checkpoint
and archive files.

If you would like more assistance from technical support and don't have a support contract, please contact our sales team to discuss this further.

In the mean time I hope this helps,
Jen.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users