Jump to content


Fetching/clone from remote

fetch clone remote

  • Please log in to reply
2 replies to this topic

#1 darrenc

darrenc

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 26 July 2020 - 10:37 AM

Hi,

I'm struggling with getting my head around the fetching of a remote server (This is the second project I've tried and seem to be getting the same result). I'm thinking that It's my lack of understanding of how it's working and hoping someone could point me in the right direction.

A client is running their own perforce server, the idea was we would clone their server to an office server, then my team would connect to the office server.
The client setup a branch on his own server that he would push any changes to.
We would then fetch any of these changes and integrate in our own codebase.

To get our office server setup I used the clone command on the remote server.
The clone command setup a personal server and I changed some of the configs to allow for our local developers to access the server.

Each of the local developers are directly connected to the office server (they didn't clone)

The problem I'm having is the fetch command seems to have stopped working with conflict errors.
After running "p4 fetch -r origin -t)
"can't delete modified file"
"conflict change 9 //path/file#2(edit)"
Then nothing seems to happen;
"0 conflicting change(s) were relocated to //tangent/000016"


I'm unsure where to go from here, any pointers would be great - even if it's pointing out I've got the wrong end of the stick :)

Thanks
Darren

#2 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 1148 posts

Posted 26 July 2020 - 02:44 PM

The first part of the error is pretty clear -- change 9 edited a file that the origin has deleted, so that edit conflicts with the delete.  In that instance the locally conflicting change is supposed to get kicked aside into a "tangent" depot to make space for the origin change.

Have you set up the permissions/configurables as described here in "p4 help fetch"?

		The -t flag specifies that conflicting changes should be moved to
		a new tangent, as described earlier. The -t flag requires the -r
		flag. The -t flag also requires that an administrator has set
		server.allowrewrite=1. In order to use the -t flag, you must have
		admin access to the files to be fetched.


#3 darrenc

darrenc

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 26 July 2020 - 06:10 PM

Yes server.allowrewrite=1 has been set, I did have some successful fetches to begin with but this was before anybody else had started submitting anything.

PS D:\***\clone> p4 fetch -r origin -t
Conflict: change 9 //***/console/***/Config/DefaultInput.ini#2 (edit).
Conflict: change 9 //***/console/***/file1.uasset#2 (edit).
Conflict: change 9 //***/console/***/file2.uasset#2 (edit).
Conflict: change 9 //***/console/***/Source/***/***_file3.cpp#2 (edit).
Conflict: change 47 //***/console/***/Source/***/***_file4.cpp#3 (edit).
Conflict: change 47 //***/console/***/Source/***/***_file5.cpp#2 (edit).
0 conflicting change(s) were relocated to '//tangent/000020/...'.
Run 'p4 resubmit' to resolve and resubmit conflicting change(s).

This is my view from p4admin, as you can see previous (failed) tries did create tangents, but it's stopped creating them.
Posted Image





Also tagged with one or more of these keywords: fetch, clone, remote

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users