Jump to content


Windows knows the file is in the directory; P4V doesn't


  • Please log in to reply
3 replies to this topic

#1 Orthoducks

Orthoducks

    Member

  • Members
  • PipPip
  • 19 posts

Posted 17 August 2020 - 04:50 PM

This problem may go away if I try it again tomorrow, but I'd like to understand it in case it happens again.

I've got a Word document file in a depot. I created a PDF from it: same directory, same, filename, only the filetype is different. I want to add the PDF to the depot too.

I click the document file (for convenience).and select the Workspace tab. The PDF should appear right next to the document file. It isn't there. I select View > Refresh All, which should make P4V display any recent addition to the directory. It still isn't there.

I not only don't know what is causing this; I can't imagine what could possibly be causing it. Any ideas?

#2 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 1191 posts

Posted 17 August 2020 - 08:00 PM

Do you have any filters defined in the workspace tab?

Does the file show up in the native shell (Explorer etc)?

What happens if you "p4 add" it from the command line?

#3 Orthoducks

Orthoducks

    Member

  • Members
  • PipPip
  • 19 posts

Posted 18 August 2020 - 05:43 AM

> Do you have any filters defined in the workspace tab?

No.

> Does the file show up in the native shell (Explorer etc)?

Yes -- if it did not, this would be an Acrobat puzzle, not a Perforce puzzle.

> What happens if you "p4 add" it from the command line?

Don't know, because when I returned to the problem tonight, the file was visible... as I suspected it would be.

I then found an error which obliged me to delete and recreate the PDF. This time it again appeared in File Explorer but not in P4V's workspace view, through several refreshes. Again, after some time passed it appeared in workspace view and I committed it.

If this happens again I can try adding it from the command line when P4V doesn't see it, and I'll let you know what happens.

#4 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 1191 posts

Posted 18 August 2020 - 04:08 PM

If it shows up in P4V eventually, as opposed to being absent because of some kind of filtering, then it sounds like it's a bug in P4V's refresh logic.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users