Jump to content


Set character encoding is not working in P4Merge


  • Please log in to reply
4 replies to this topic

#1 ytt1515234

ytt1515234

    Member

  • Members
  • PipPip
  • 13 posts

Posted 09 October 2020 - 07:03 AM

Hi,

our P4 server is unicode mode, and we are using "utf-8 no bom" when connnected. But if I diff a file, whatever I changed in Perferences->Character encoding, it's not working.
123.png

if I changed it in File->Character Encoding, it will work, but cannot save which means I have to choose again in the next time.
222.png

Is anyone has any idea about this? thanks a lot.

FYI, P4 server version is 2020, P4V I have tried with 2015, 2019 and 2020, and the result is the same.

#2 p4crenck

p4crenck

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 19 October 2020 - 08:24 PM

The encoding defined in the P4Merge Preferences is the one used when you launch it. You can then change the encoding for the current session by selecting the menu File->Character Encoding.

If you're launching P4Merge from P4V, P4V passes its current encoding to P4Merge, overriding its preferences.
The only workaround would be to define P4Merge as a 3rd party Diff/Merge tool in P4V Preferences.  Then the P4Merge encoding preference you set will be used.
Hope this helps

#3 ytt1515234

ytt1515234

    Member

  • Members
  • PipPip
  • 13 posts

Posted 20 October 2020 - 06:14 AM

View Postp4crenck, on 19 October 2020 - 08:24 PM, said:

The encoding defined in the P4Merge Preferences is the one used when you launch it. You can then change the encoding for the current session by selecting the menu File->Character Encoding.

If you're launching P4Merge from P4V, P4V passes its current encoding to P4Merge, overriding its preferences.
The only workaround would be to define P4Merge as a 3rd party Diff/Merge tool in P4V Preferences.  Then the P4Merge encoding preference you set will be used.
Hope this helps

Hi, thanks for the reply, we have tried to set in p4merge preferences, but it looks like not working.

When I start P4Merge by diff files, the encoding is "System" by default, but I already set it to "utf8 no bom" in the preference (our system encoding is not utf8)
1234.png

#4 p4crenck

p4crenck

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 22 October 2020 - 01:12 AM

Hi, are you launching P4Merge from P4V? Also, make sure you are running the latest versions of P4V and P4Merge.

#5 ytt1515234

ytt1515234

    Member

  • Members
  • PipPip
  • 13 posts

Posted 22 October 2020 - 06:21 AM

View Postp4crenck, on 22 October 2020 - 01:12 AM, said:

Hi, are you launching P4Merge from P4V? Also, make sure you are running the latest versions of P4V and P4Merge.

yes, I diff a file in P4V, and the version is Rev. P4V/NTX64/2020.2/2013107

FYI, I have updated to Rev. P4V/NTX64/2020.2/2028073, but the problem is still there.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users