Jump to content


balintn's Content

There have been 6 items by balintn (Search limited from 28-May 19)


By content type

See this member's

Sort by                Order  

#14908 Installing P4V for Visual Studio 2010

Posted by balintn on 19 August 2014 - 10:22 PM in P4V

Thank you!

However, it wasn't straightforward to open a solution that is already under source control.
Here is how to do that.:
- Visual Studio / Tools / Extension Manager
- Search for p4VS
- Install P4VS
- Use P4V to check out the solution file (.sln)
- Tools / Options / Source Control / Plugin Selection / P4VS - ...

- Open solution - File / Open Solution from Perforce Depot (this way it will ask for P4 sredentials for the first time)



#14899 Installing P4V for Visual Studio 2010

Posted by balintn on 19 August 2014 - 07:42 AM in P4V

I have Perforce Client installed for a VS2013 client.
However, I also have a VS2010 environment, that does not see the P4V integrated client.
How can I use Perforc frmthe VS2010 environment as well?
P4V is 2014.1



#14753 Visual Studio 2013 temporarily work uncontrolled with P4?

Posted by balintn on 01 August 2014 - 09:28 AM in General

I've been using P4 with Visual Studio 2005, 2008, 2010 for a long time.
I recently switched to VStudio 2013 plus P4VS.
When I work disconnected from the P4 server, after the failed connection attempt VS starts as if my solution was not under source control.
Previously, in this case VS asked what I wanted to do (Work Temporarily Uncontrolled, Change SC Binding, Permanently Remove SC Bindings).
Can I restore that behavior?

(I know that this is much more a VStudio question, but I think this is the place where I could get an answer...)



#11918 Problem switching server to unicode

Posted by balintn on 28 November 2013 - 12:22 PM in Administration

Now it works (it produces the non-UTF8 errors mentioned in the How to article).
I will follow that conversion process.

In my case the problem was that $P4ROOT was not set by default.
So, this is a note to anyone with default installations: use this:
p4d -xi -r<directory of your p4d.exe>

Thanks,
B



#11703 Problem switching server to unicode

Posted by balintn on 24 November 2013 - 04:09 PM in Administration

Hi!
We had some accented character translation problems in Visual Studio vdproj files.
We believe that accented characters are corrupted when checked in/out of Perforce server.
As a countermeasure, I'd like to switch our Perforce server to unicode.
I followed the instructions here: https://kb.perforce....na..tionSupport
- stopped the Perforce service
- issued p4d -xi (which stated the server was switched to unicode)
- restarted the service
However,
- when I issue "p4 counters", the unicode counter is not present
- when I try to submit a filetype change to unicode, I get the error "cannot submit unicode type file using non-unicode server"

What am I missing?
- Server is running on Windows.
- Program files / Perforce / p4.exe version is 2013.1.68.5046
- Program files / Perforce / Server / p4d.exe, p4s.exe version is 2013.1.71.548

Any help is appreciated.



#11040 20-20 edition allows only 2 users

Posted by balintn on 29 September 2013 - 04:22 PM in General

I downloaded the 20-20 edition (version 2013.1 32 bit), but the Administration tool shows License total: 2.
Is this normal?
Is there anything to do to get the 20 user license?

Thanks,
B