Jump to content


dkm's Content

There have been 4 items by dkm (Search limited from 04-April 19)


By content type

See this member's

Sort by                Order  

#25351 SSL setup problem, can't connect from client.

Posted by dkm on 11 September 2019 - 07:43 AM in Administration

Thanks for the answer.
Sorry, I forgot to update the thread. I managed after redoing the procedure a couple more times.

I think it had to do with the permissions on my 'sslkeys' folder somehow. Well anyway, I eventually managed! :huh:



#25321 SSL setup problem, can't connect from client.

Posted by dkm on 01 September 2019 - 01:29 PM in Administration

Hi,

Sorry if this sound like a pretty trivial problem, but I just can't seem to get ssl working.
I have perforce running on raspbian and everything works fine, but after trying to add ssl I get this error when trying to connect form the client:

SSL connect to ssl:192.168.3.11:1666 failed .
	Remove SSL protocol prefix from P4PORT or fix the TLS settings.

Nothing fancy for the setup:

sudo mkdir /Perforce/sslkeys
sudo chmod 700 /Perforce/sslkeys
export P4PORT=ssl:192.168.3.11:1666
export P4SSLDIR=/Perforce/sslkeys
sudo p4d -Gc
sudo p4d -Gf

It said the certificate and fingerprints were created properly.

p4 set / p4 info after starting the server gives this:
pi.jpg

If anyone has an idea of what I'm doing wrong, that'd be super helpful!
Been trying a couple of times and pulling my hair off...
Thanks!



#25058 P4 on Raspberry Pi 4

Posted by dkm on 13 July 2019 - 06:02 AM in General

Alright, thanks for the answer.



#25001 P4 on Raspberry Pi 4

Posted by dkm on 06 July 2019 - 06:33 AM in General

Hi,

I'm thinking of hosting a small perforce server and I was wondering if it would run on a Raspberry Pi 4. (hopefully running raspbian rather than windows)
Anyone knows if there are some compatibility issues or anything that would prevent that?

Thanks in advance!